Автор Тема: Что за метод ПолучитьСодержимое() ?  (Прочитано 360 раз)

0 Пользователей и 1 Гость просматривают эту тему.

bossiii333

  • Новичок
  • *
  • Сообщений: 6
  • ФИО: Ильясов Ильдар Ильясович
Здравствуйте форумчане, может кто-то объяснить, что это за метод такой ПолучитьСодержимое() ? Нигде нет описания. Дело происходит в модуле формы обработки.

 

&НаКлиенте
Процедура КомандаПолучитьОкна(Команда)
   
   СсылкаНаНовыйЭлемент = ДобавитьЭлементНаСервере();
   
   КоллекцияОкон = ПолучитьОкна();
   Для Каждого Окно из КоллекцияОкон Цикл
       Если НЕ Окно.Основное Тогда   // от основного окна нельзя получить формы
           Форма = Окно.ПолучитьСодержимое();
           СписокТоваров = Форма.Элементы.Найти("Список");
           Если СписокТоваров <> Неопределено Тогда   // если есть элемент Список - обновить его
               СписокТоваров.Обновить();
           КонецЕсли;   
       КонецЕсли;
   КонецЦикла;   
   
КонецПроцедуры

nonameforme

  • Пользователь
  • **
  • Сообщений: 12
  • ФИО: Дмитрий
Re: Что за метод ПолучитьСодержимое() ?
« Ответ #1 : Май 24, 2022, 09:03:30 am »
А ты на какой версии платформы работаешь?

У тебя стоит режим совместимости 8.2.16. Скорее всего этот метод переименовали в Содержимое() в версии 8.3


bossiii333

  • Новичок
  • *
  • Сообщений: 6
  • ФИО: Ильясов Ильдар Ильясович
Re: Что за метод ПолучитьСодержимое() ?
« Ответ #2 : Май 24, 2022, 10:13:38 am »
1С:Предприятие 8.3, учебная версия (8.3.19.1150)

bossiii333

  • Новичок
  • *
  • Сообщений: 6
  • ФИО: Ильясов Ильдар Ильясович
Re: Что за метод ПолучитьСодержимое() ?
« Ответ #3 : Май 26, 2022, 12:44:46 pm »
А ты на какой версии платформы работаешь?

У тебя стоит режим совместимости 8.2.16. Скорее всего этот метод переименовали в Содержимое() в версии 8.3
Спасибо большое.