Автор Тема: Бесплатно. Вообще! Курс "с нуля до 1С:Специалист"  (Прочитано 71565 раз)

0 Пользователей и 1 Гость просматривают эту тему.

OlegK

  • Пользователь
  • **
  • Сообщений: 60
Re: Бесплатно. Вообще! Курс "с нуля до 1С:Специалист"
« Ответ #60 : Январь 17, 2021, 06:42:01 pm »
Можно здавать с 8.2
прорешать самому 15 бил  от и до . не смотря на здешние решения ибо все они кривые.

можно их брать как скелет для разбора но в код даже не смотреть .ошибка на ошибке.

удачи в подготовке . я не Павел но помочь всегда за. коллега.

Спасибо! С задачами буду разбираться после курса. А пока, основной вопрос был относительно актуальности курса и ответить на него может только Павел Чистов, т.к. это его курс и он работает в Учебном центре.

Sadr

  • Пользователь
  • **
  • Сообщений: 57
  • Спец: Платформа, БП, УТ, ЗУП
  • ФИО: АС
Re: Бесплатно. Вообще! Курс "с нуля до 1С:Специалист"
« Ответ #61 : Январь 18, 2021, 12:35:02 am »

... ответить на него может только Павел Чистов, т.к. это его курс и он работает в Учебном центре.


Думаю наоборот, Павлу сложно будет ответить "можно ли сдать экзамен" посмотрев только Спецкурс и/или нужен оф.курс, проще будет ответить сдавшим, посмотрев курс(ы).


OlegK

  • Пользователь
  • **
  • Сообщений: 60
Re: Бесплатно. Вообще! Курс "с нуля до 1С:Специалист"
« Ответ #62 : Январь 18, 2021, 12:45:23 am »

... ответить на него может только Павел Чистов, т.к. это его курс и он работает в Учебном центре.


Думаю наоборот, Павлу сложно будет ответить "можно ли сдать экзамен" посмотрев только Спецкурс и/или нужен оф.курс, проще будет ответить сдавшим, посмотрев курс(ы).

Я так вопрос не ставил, можно ли сдать посмотрев этот курс или нужен курс 1С. Дело совсем в другом. Например, в свое время оплатил курс по ЗУП и не сразу зарегистрировался, а потом перед регистрацией что-то подсказало спросить, все ли в силе. Ответ был примерно таким: "Курс уже устарел и больше не подходит для подготовки к сдаче экзамена. Можете выбрать любой другой курс". При этом регистрация на него была по прежнему доступна и если бы я зарегистрировался, то впустую потратил время и деньги. Через некоторое время вышел обновленный курс.

Rus07

  • Новичок
  • *
  • Сообщений: 1
Re: Бесплатно. Вообще! Курс "с нуля до 1С:Специалист"
« Ответ #63 : Апрель 23, 2021, 06:08:48 pm »
Халява кончилась ? )

Холодный Тимофей

  • Пользователь
  • **
  • Сообщений: 22
  • ФИО: Тимофей Александрович Холодный
Re: Бесплатно. Вообще! Курс "с нуля до 1С:Специалист"
« Ответ #64 : Апрель 23, 2021, 10:55:54 pm »
Добрый день, хотелось бы уточнить по поводу "Представления" в запросах (Номенклатура.Представление), его необходимо использовать во всех случаях когда мы получаем наименование, или всё таки только в проводимых документах, а в отчетах нет такой необходимости, а то посмотрел уже половину курса(может быть где то дальше и будет), но так и не понял, где то на этом акцентировалось внимание что это запрос в цикле, а потом как то тема с "представлением" поутихла
Представление необходимо получать там, где будет использовано только текстовое представление ссылки на элемент Справочника/документа/ПВХ и др ссылочных типов, те чаще всего для взаимодействия с пользователем. В СКД как раз и выводится представление, только это происходит автоматически.
Конкретно в случае проведения документа оно используется в цикле для вывода сообщения пользователю о нехватке товара. При этом, если будет использована ссылка, то платформа автоматически будет генерить запрос на получение представления. А это запрос в цикле или смертный грех по версии экзаменаторов.

malinapc

  • Пользователь
  • **
  • Сообщений: 45
Только ОЧЕНЬ ленивый человек не найдет материалы, которые публичны, лежат на YouTube и моем сайте. Ну это вот крайне сложно.
Но я таки все собрал в одну кучку, и теперь всем должно быть проще :) https://chistov.pro/projects/speccourse/

Спасибо!

Здравствуйте, Павел. Очень познавательный курс. Но вот беда занятие 19 почему то не открывается:

Занятие 019
Регистр бухгалтерии, механизм субконто

https://www.youtube.com/watch?v=RwlcMOhjiq

Говорит это видео недоступно, в разных браузерах пробовал открыть. Посмотрите, пожалуйста. Спасибо.

GROOVY

  • Администратор
  • Старожил
  • *****
  • Сообщений: 284
  • ФИО: Павел Чистов
Не знаю что за видео Вы хотите просмотреть https://chistov.pro/projects/speccourse/ в плейлисте все открывается включая и 19е видео.

malinapc

  • Пользователь
  • **
  • Сообщений: 45
В проведении Расходной накладной Курс в цикле зачем то получается столько раз сколько строк в цикле

#Область БухОПТ

   Движения.РегистрБухгалтерии.Записать(); //Очищаем регистр бухгалтерии

   Запрос.Текст =
   "ВЫБРАТЬ
   |   ДокТЧ.Номенклатура КАК Номенклатура,
   |   МАКСИМУМ(ДокТЧ.Количество) КАК Количество,
   |   МАКСИМУМ(ДокТЧ.Сумма) КАК Сумма,
   |   СУММА(РегистрБухгалтерииОстатки.СуммаОстаток) КАК СуммаОстаток,
   |   СУММА(РегистрБухгалтерииОстатки.УпрСуммаОстаток) КАК УпрСуммаОстаток,
   |   СУММА(РегистрБухгалтерииОстатки.КоличествоОстаток) КАК КоличествоОстаток,
   |   СУММА(ВЫБОР
   |         КОГДА РегистрБухгалтерииОстатки.Субконто2 = &Склад
   |            ТОГДА РегистрБухгалтерииОстатки.КоличествоОстаток
   |      КОНЕЦ) КАК ОстатоКПоСкладу
   |ИЗ
   |   ДокТЧ КАК ДокТЧ
   |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрБухгалтерии.РегистрБухгалтерии.Остатки(
   |            &МоментВремени,
   |            Счет = &Счет,
   |            &МассивСубконто,
   |            Субконто1 В
   |               (ВЫБРАТЬ
   |                  ДокТЧ.Номенклатура
   |               ИЗ
   |                  ДокТЧ КАК ДокТЧ)) КАК РегистрБухгалтерииОстатки
   |      ПО ДокТЧ.Номенклатура = РегистрБухгалтерииОстатки.Субконто1
   |
   |СГРУППИРОВАТЬ ПО
   |   ДокТЧ.Номенклатура";
   
   Запрос.УстановитьПараметр("Счет", ПланыСчетов.ПланСчетов.ТоварыОпт);
   Массив = Новый Массив(2);
   Массив
  • = ПланыВидовХарактеристик.ВидыСубконто.Номенклатура;

   Массив [1] = ПланыВидовХарактеристик.ВидыСубконто.Склады;
   Запрос.УстановитьПараметр("МассивСубконто", Массив);
   
   Результат = Запрос.Выполнить();
   Выборка = Результат.Выбрать();

   Пока Выборка.Следующий() Цикл
      
      //Сообщить("Остатки по БУХ: " + Выборка.КоличествоОстаток);
      Если Выборка.Количество > Выборка.ОстатоКПоСкладу Тогда
         Сообщить("Мало товара");
         Отказ = Истина;
      КонецЕсли;
      
      Если Отказ Тогда
         Продолжить;
      КонецЕсли;
      
      Себестоимость = Выборка.Количество / Выборка.КоличествоОстаток * Выборка.СуммаОстаток;
      УпрСебестоимость = Выборка.Количество / Выборка.КоличествоОстаток * Выборка.УпрСуммаОстаток;
      
      //Списание товаров (себестоимость)
      Проводка = Движения.РегистрБухгалтерии.Добавить();
      Проводка.Период = Дата;
      Проводка.СчетДт = ПланыСчетов.ПланСчетов.Прибыль;
      Проводка.СчетКт = ПланыСчетов.ПланСчетов.Товары;
      Проводка.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Номенклатура] = Выборка.Номенклатура;
      Проводка.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконто.Номенклатура] = Выборка.Номенклатура;
      Проводка.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконто.Склады] = Склад;
      Проводка.КоличествоКт = Выборка.Количество;
      Проводка.Сумма = Себестоимость;
      Проводка.УпрСумма = УпрСебестоимость;
      
      Курс = ВозвращаемыеЗначения.ПолучитьКурсУпрВалюты(НачалоДня(Дата));
      
      //Регистрация долга покупателя
      Проводка = Движения.РегистрБухгалтерии.Добавить();
      Проводка.Период = Дата;
      Проводка.СчетДт = ПланыСчетов.ПланСчетов.Покупатели;
      Проводка.СчетКт = ПланыСчетов.ПланСчетов.Прибыль;
      Проводка.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконто.Номенклатура] = Выборка.Номенклатура;
      Проводка.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Контрагенты] = Контрагент;
      Проводка.Сумма = Выборка.Сумма;
      Проводка.УпрСумма = Выборка.Сумма / Курс;

      
   КонецЦикла;
   
#КонецОбласти