Домены .RU/.РФ

Автор Тема: Задача 2.08  (Прочитано 1871 раз)

0 Пользователей и 1 Гость просматривают эту тему.

term1t

  • Новичок
  • *
  • Сообщений: 0
  • ФИО: Роман
Задача 2.08
« : Июль 15, 2013, 12:16:27 pm »
Есть же ценовые группы, полностью подходящие под описание задачи, зачем изобретать велосипед?

 Если не использовать ценовые группы, я решил так: 
 1) Создаем вид цен "По произвольным коэффицентам" с типом наценка на базовый тип 
 2) Задаем базовый вид цен и наценку на него
 3) Добавляем в карточку ном-ры ревизит с наценкой
 4) И заменяем формулу расчета цены из документа установки цен по условию

 
Код
Если ВидЦены.СпособЗаданияЦены = Перечисления.СпособыЗаданияЦен.РассчитыватьПоФормуламОтДругихВидовЦен Тогда
                    Формула = ВидЦены.Формула;
                      Иначе
                             Если ПозицияНоменклатуры.Номенклатура.ПроцентНаценки <> 0 И ВидЦены.Наименование = "По произвольным коэффицентам" Тогда   
                    Формула = "[" + ВидЦены.БазовыйВидЦены + "]*" + Формат(((ПозицияНоменклатуры.Номенклатура.ПроцентНаценки/100)+1),"ЧРД=.; ЧГ=0");
                             Иначе
                    Формула = "[" + ВидЦены.БазовыйВидЦены + "]*" + Формат(((ВидЦены.Наценка/100)+1),"ЧРД=.; ЧГ=0");
                    КонецЕсли;
                          КонецЕсли;
                   КонецЕсли;


 Кто как еще решил?
« Последнее редактирование: Июль 15, 2013, 02:23:26 pm от Роман »
Специалист по платформе
 Проф УТ, Проф Розница, Проф Платформа

Gray

  • Новичок
  • *
  • Сообщений: 0
  • ФИО: Кузнецов Евгений
Задача 2.08
« Ответ #1 : Июль 17, 2013, 11:09:29 pm »
А вид цен типа "Произвольный запрос к данным ИБ" слабо сделать? Тут даже конфигурацию править не потребуется.

LepRiKonS

  • Пользователь
  • **
  • Сообщений: 49
    • www.korolevpavel.ru
  • ФИО: Павел
Задача 2.08
« Ответ #2 : Январь 03, 2014, 01:54:51 pm »
Gray, а как Вы определите наценку на конкретную номенклатурную позицию без изменения конфигурации?

Martovicka

  • Новичок
  • *
  • Сообщений: 0
  • ФИО: Inna Martovicka
Задача 2.08
« Ответ #3 : Май 07, 2014, 01:54:21 pm »
Есть такой вариант решения через произвольную схему компоновки с точечным дорабатываем функционала.
Вложения:
2.8_.docx

MariaVG

  • Проверенный
  • ***
  • Сообщений: 113
Re: Задача 2.08
« Ответ #4 : Июль 21, 2017, 10:41:51 pm »
Попадалась ли похожая задача кому-нибудь на экзамене?
Настройка произвольного запроса в пользовательском режиме - это хорошо, но смущает формулировка: "необходимо реализовать возможность использования способа задания цены  при определении вида цены".  То, что мы делаем, настраивая этот вид цены сами - это уже непосредственно настройка конкретного вида цены. Не идет ли здесь речь о том, чтобы создать собственный макет установки цен в конфигураторе как шаблон для дальнейшего использования? Например, если пользователи захотят по данному правилу настроить несколько разных видов цен, зависящих от разных базовых? Или же все-таки на экзамене нормально принимается вариант с настройкой запроса в пользовательском режиме? Получается, что здесь палка о двух концах. Если не делать в пользовательском режиме, можно сказать, что не используем возможности системы. Но, с другой стороны, это задача по конфигурированию и немного странно решать ее даже не входя в конфигуратор. Может быть, от нас здесь хотят все-таки, чтобы наш шаблон появлялся в списке других предопреденных, или не стоит так заморачиваться?