Автор Тема: Не явная транзакция в форме объекта  (Прочитано 3519 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Droni

  • Модератор
  • Пользователь
  • *****
  • Сообщений: 97
Re: Не явная транзакция в форме объекта
« Ответ #15 : Май 22, 2015, 03:12:29 pm »
Вы увидели противоречие ? Возвращаясь к нашему вопросу о неявных блокировках в вопросе экзаменатора. Ведь это тоже противоречие. Управляемый блок только для чтения НабораЗаписей (А. Морозов - "По сути, НаборЗаписей является исключением из правила. Во всех остальных случаях разработчик должен сам всегда следить и устанавливать управляемую блокировку.")? Верно? А Филиппов говорит, что уже нет. Вы согласны? Я правильно размышляю?
Можете это проверить? У меня аллергия на ТЖ, а вы ловко с ним управляетесь )

Мне не удалось смоделировать ситуацию, что бы получение свойства объекта через ссылку было выполнено с установкой управляемой блокировки по читаемому объекту.
Для управляемой формы из формы списка документа выполнялось:

&НаКлиенте
Процедура СписокПриАктивизацииЯчейки(Элемент)
   СписокПриАктивизацииЯчейкиНаСервере(Элементы.Список.ТекущаяСтрока);
КонецПроцедуры

&НаСервереБезКонтекста
Процедура СписокПриАктивизацииЯчейкиНаСервере(СсылкаНаДокумент)
   проведен = СсылкаНаДокумент.Проведен;
КонецПроцедуры

Для обычных форм из формы списка документа выполнялось:

Процедура ДокументСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
   Проведен = ДанныеСтроки.Ссылка.Проведен;   
КонецПроцедуры

Droni

  • Модератор
  • Пользователь
  • *****
  • Сообщений: 97
Re: Не явная транзакция в форме объекта
« Ответ #16 : Июнь 10, 2015, 11:10:12 am »
Видимо они все таки есть ...
http://1c.ru/news/info.jsp?id=20040
Цитировать
3.   отслеживать неявные транзакции в отчетах и формах списков;

blizz1205

  • Пользователь
  • **
  • Сообщений: 23
Re: Не явная транзакция в форме объекта
« Ответ #17 : Ноябрь 26, 2015, 10:36:55 am »
Цитировать
Или попадетесь на то, что в динамическом списке возможна транзакция, ответите нет - получите минус.
Интересно спрашивают ли сейчас этот вопрос на экзамене. Но решил посмотреть это на практике. Транзакции в динамическом списке действительно есть.

В первой цитате говорится о транзакции, во второй о управляемой взаимоблокировке. Так про что спрашивал экзаменатор, про неявную транзакцию или неявную управляемую блокировку?

Порадовал термин "управляемая взаимоблокировка" :D. Хотя он верный с той точки зрения, что им оперирует 1С в тестах на профессионала.
« Последнее редактирование: Ноябрь 26, 2015, 11:50:04 pm от blizz1205 »

Ваша реклама могла бы быть тут...