Ваша реклама могла бы быть тут...

Автор Тема: Билет 5. Спец по платформе V8  (Прочитано 39206 раз)

0 Пользователей и 1 Гость просматривают эту тему.

letyurij

  • Пользователь
  • **
  • Сообщений: 38
Re: Билет 5. Спец по платформе V8
« Ответ #345 : Июль 06, 2019, 08:14:34 pm »
Да именно так. Штраф — это невыход, у которого есть результат.

серж

  • Пользователь
  • **
  • Сообщений: 65
Re: Билет 5. Спец по платформе V8
« Ответ #346 : Июль 06, 2019, 10:04:00 pm »
Да именно так. Штраф — это невыход, у которого есть результат.
Невыход - это когда чел не вышел на работу, т.е. минус 1 фактический рабочий день. Во всех задачах так и написано - "невыход".
Штраф - это удержание, не влияющее на результаты всех прочих расчетов.
Специалист ЗУП `2018
Полезные ссылки для подготовки к сдаче на специалиста по ЗУП: https://expert.chistov.pro/public/923534/

letyurij

  • Пользователь
  • **
  • Сообщений: 38
Re: Билет 5. Спец по платформе V8
« Ответ #347 : Июль 07, 2019, 07:55:12 am »

Комментарий:

Штраф это не начисление, величина штрафа не увеличивает размер выплат сотруднику. Если бы вы сделали его вытесняющим оклад (возможно при ОПРЕДЕЛЕННОЙ настройке регистра сведений графика), то размещение его в данном ПВР было бы оправдано.


Что же это за ОПРЕДЕЛЕННАЯ настройка регистра такая? Давайте разбираться.

По условию задачи: "Сотрудники предприятия получают оплату по окладу пропорционально ОТРАБОТАННОМУ времени в ЧАСАХ".
Таким образом единица измерения для оклада - "ЧАС", для штрафа -  "15 МИНУТ". Если сотрудник опоздал на 15 минут значит час не отработан, т.е. НОЛЬ. Поэтому Штраф вытесняет оклад.


Теперь надо придумать, как настроить график? В данной задаче он будет не совсем привычный — записей за каждый рабочий день будет не одна, а 32 (при 8-и часовом рабочем дне).

Например, если работаем с 9.00
09.15 - "ЗначениеЧасы"=1, "ЗначениеШтраф"=1;
09.30 - "ЗначениеЧасы"=0, "ЗначениеШтраф"=1;
09.45 - "ЗначениеЧасы"=0, "ЗначениеШтраф"=1;
10.00 - "ЗначениеЧасы"=0, "ЗначениеШтраф"=1;
и т.д.

А дальше все стандартно — запрос к таблице ДанныеГрафика. Штаф вытесняет оклад, поэтому если сотрудник опоздал на 15 и более минут, Факт времени отработанного времени за этот час будет "0". И за каждые 15 минут опоздания будет  "1".

PS. При таком большом количестве записей удобно воспользоваться обработкой примерно такого вида

Набор = РегистрыСведений.ГрафикиРаботы.СоздатьНаборЗаписей();
   Набор.Отбор.Сотрудник.Установить(Сотрудник);
   Набор.Отбор.Подразделение.Установить(Подразделение);
   Набор.Прочитать();
   
   ЧислоСекунд = 15*60;
   
   Дат = ДатаНачала;
Сч=0;         
   Пока Дат <= ДатаОкончания Цикл
      
      Если Найти(ВыходныеДни, Строка(ДеньНедели(Дат))) Тогда
         //Запись.ЗначениеЧасы = 0;
         //Запись.ЗначениеШтраф = 0;
      Иначе            
         
         Если Дата(1,1,1,Час(Дат), Минута(Дат),0) > '000101010900' и Дата(1,1,1,Час(Дат), Минута(Дат),0) <= '000101011700' Тогда
            Сч = ?(Сч=4, 1, Сч + 1);
            Запись = Набор.Добавить();
            Запись.Дата = Дат;
            Запись.Сотрудник = Сотрудник;
            Запись.Подразделение = Подразделение;
            Запись.ЗначениеШтраф = 1;
            Запись.ЗначениеЧасы = ?(Сч=1, 1, 0);
         КонецЕсли;
         
      КонецЕсли;
      Дат = Дат + ЧислоСекунд;
   КонецЦикла;
   Набор.Записать();


серж

  • Пользователь
  • **
  • Сообщений: 65
Re: Билет 5. Спец по платформе V8
« Ответ #348 : Июль 07, 2019, 11:15:29 am »
   Из комментария экзаменатора следует, что вытеснение возможно, но не обязательно.
 Т.е. если мы претендуем на 5 и имеем в запасе достаточно времени, то можно заморочиться.
ps: а откуда это описание решения ? я не видел такого в тех курсах, которых смотрел ранее.
Специалист ЗУП `2018
Полезные ссылки для подготовки к сдаче на специалиста по ЗУП: https://expert.chistov.pro/public/923534/

letyurij

  • Пользователь
  • **
  • Сообщений: 38
Re: Билет 5. Спец по платформе V8
« Ответ #349 : Июль 07, 2019, 02:25:26 pm »
   Из комментария экзаменатора следует, что вытеснение возможно, но не обязательно.
 Т.е. если мы претендуем на 5 и имеем в запасе достаточно времени, то можно заморочиться.
ps: а откуда это описание решения ? я не видел такого в тех курсах, которых смотрел ранее.

Подобная задача (только там штраф за каждые 30 минут) есть в домашних задачах на курсах П.С.Белоусова, где он подробно расказывает и показывает методику решения. Он вообще начинает с самого "низу" — с минут: "Имеем 60 записей в час, умноженные на 24 часа = 1440 записей в сутки. А потом начинаем накладывать условия задачи и сворачивать количество записей: работаем 8 часов, оплата за час — значит можно сделать только восемь записей в день. А если от нас не требуется отслеживать почасовой невыход, то вместо восьми записей со Значением=1, можно оставить только одну запись со Значением=8."

KVAS

  • Новичок
  • *
  • Сообщений: 6
Re: Билет 5. Спец по платформе V8
« Ответ #350 : Июль 11, 2019, 10:22:28 am »
Добрый день, коллеги.
Сделал 5 билет, любым замечанием буду рад.

ПР делал всё виды отдельно, расчет в итоговых значений в общем модуле. Так как в задаче не указано учитывать штраф в окладе (не учитываю). Считаю понятия штраф и прогул, два разных вида расчета.
« Последнее редактирование: Июль 11, 2019, 10:28:05 am от KVAS »

серж

  • Пользователь
  • **
  • Сообщений: 65
Re: Билет 5. Спец по платформе V8
« Ответ #351 : Июль 23, 2019, 10:02:04 pm »
 Вопрос по бизнес-процессу.
Беспокоит меня вот такая фраза: "Задана персональная адресация задач без необходимости - 1 балл".
Что тут имеется в виду ?
 Как я предполагаю, речь идет об указании в адресации задачи Основного реквизита адресации. Когда нужна возможность прямо указывать исполнителя (т.н. "персональная адресация") мы указываем этот реквизит.
 Но если в схеме бизнес-процесса исполнитель нигде прямо не задается (например Иванов), то указание основного реквизита адресации является избыточным и карается минус 1 баллом.
 Но это только предположение.
Специалист ЗУП `2018
Полезные ссылки для подготовки к сдаче на специалиста по ЗУП: https://expert.chistov.pro/public/923534/