Автор Тема: Билет 2. Спец по платформе V8  (Прочитано 68654 раз)

0 Пользователей и 1 Гость просматривают эту тему.

GROOVY

  • Администратор
  • Старожил
  • *****
  • Сообщений: 261
  • ФИО: Павел Чистов
Re: Билет 2. Спец по платформе V8
« Ответ #525 : Январь 24, 2020, 12:17:32 pm »
Добрый день.
Друзья, можете сказать по каким причинам не стартует регламентное задание, может есть где-то какая-то тонкость?
Не настроено расписание, не указано что оно предопределенное, старая версия платформы.
The Truth Is Out There...

Новобранец

  • Пользователь
  • **
  • Сообщений: 69
Re: Билет 2. Спец по платформе V8
« Ответ #526 : Январь 24, 2020, 01:03:05 pm »
Павел, рад видеть и приветсвовать столь узнаваемого и уважаемого человека. Это настроено. Версия Версия 8.3.12


Новобранец

  • Пользователь
  • **
  • Сообщений: 69
Re: Билет 2. Спец по платформе V8
« Ответ #527 : Январь 24, 2020, 05:12:48 pm »
Павел, рад видеть и приветсвовать столь узнаваемого и уважаемого человека. Это настроено. Версия Версия 8.3.12
Павел понизил версию платформы, заработало, но не ясно почему это так происходит, в связи с  чем  :-\ :-\ :-\ :-\ :-\ :-\ :-\

letyurij

  • Пользователь
  • **
  • Сообщений: 87
Re: Билет 2. Спец по платформе V8
« Ответ #528 : Январь 24, 2020, 07:29:06 pm »
Павел понизил версию платформы, заработало, но не ясно почему это так происходит, в связи с  чем
В файловом варианте довольно частое явление. С чем связано? ХЗ
На экзамене флаг "Предопределенное" лучше снять, а запускать задание обработкой типа "КонсольЗаданий". Есть на ИТС

В каркасной такой нет, но можно быстро сделать свою.

&НаСервереБезКонтекста
Процедура СоздатьРегламентноеЗаданиеНаСервере()
   
    РеглЗадание = РегламентныеЗадания.СоздатьРегламентноеЗадание("ФормированиеЗадач");
    РеглЗадание.Наименование = "Новая задача";
    РеглЗадание.Использование = Истина;
    Расписание = Новый РасписаниеРегламентногоЗадания;
    Расписание.ВремяНачала = ВыбрВремя;
    Расписание.ПериодПовтораДней = 1;
    РеглЗадание.Расписание = Расписание;
    РеглЗадание.Записать();
   
КонецПроцедуры

&НаКлиенте
Процедура СоздатьРегламентноеЗадание(Команда)
    СоздатьРегламентноеЗаданиеНаСервере();
КонецПроцедуры
« Последнее редактирование: Январь 24, 2020, 07:33:18 pm от letyurij »
1С 8.3: Специалист по Платформе
1С 7.7: Специалист Бухгалтерия
1С 7.7: Специалист Зарплата и Кадры
Опыт работы с 1994 года.

GROOVY

  • Администратор
  • Старожил
  • *****
  • Сообщений: 261
  • ФИО: Павел Чистов
Re: Билет 2. Спец по платформе V8
« Ответ #529 : Январь 25, 2020, 11:44:31 am »
Павел, рад видеть и приветсвовать столь узнаваемого и уважаемого человека. Это настроено. Версия Версия 8.3.12
Павел понизил версию платформы, заработало, но не ясно почему это так происходит, в связи с  чем  :-\ :-\ :-\ :-\ :-\ :-\ :-\

Да кто его знает... Спишем все на мистику...
The Truth Is Out There...

Новобранец

  • Пользователь
  • **
  • Сообщений: 69
Re: Билет 2. Спец по платформе V8
« Ответ #530 : Январь 26, 2020, 02:43:26 pm »
Павел понизил версию платформы, заработало, но не ясно почему это так происходит, в связи с  чем
В файловом варианте довольно частое явление. С чем связано? ХЗ
На экзамене флаг "Предопределенное" лучше снять, а запускать задание обработкой типа "КонсольЗаданий". Есть на ИТС

В каркасной такой нет, но можно быстро сделать свою.

&НаСервереБезКонтекста
Процедура СоздатьРегламентноеЗаданиеНаСервере()
   
    РеглЗадание = РегламентныеЗадания.СоздатьРегламентноеЗадание("ФормированиеЗадач");
    РеглЗадание.Наименование = "Новая задача";
    РеглЗадание.Использование = Истина;
    Расписание = Новый РасписаниеРегламентногоЗадания;
    Расписание.ВремяНачала = ВыбрВремя;
    Расписание.ПериодПовтораДней = 1;
    РеглЗадание.Расписание = Расписание;
    РеглЗадание.Записать();
   
КонецПроцедуры

&НаКлиенте
Процедура СоздатьРегламентноеЗадание(Команда)
    СоздатьРегламентноеЗаданиеНаСервере();
КонецПроцедуры

Огромное спасибо. Я полностью согласен.

Новобранец

  • Пользователь
  • **
  • Сообщений: 69
Re: Билет 2. Спец по платформе V8
« Ответ #531 : Январь 26, 2020, 02:47:31 pm »
Павел, рад видеть и приветсвовать столь узнаваемого и уважаемого человека. Это настроено. Версия Версия 8.3.12
Павел понизил версию платформы, заработало, но не ясно почему это так происходит, в связи с  чем  :-\ :-\ :-\ :-\ :-\ :-\ :-\

Да кто его знает... Спишем все на мистику...
Павел, чудес не бывает) согласитесь. Я кажется понял почему.
1. Я создал его, но еще отлаживал по ошибкам. И скорее всего так как стоит запускать по умолчанию 3 раза, это и произошло, оно 3 раза запустилось и все.
2. Я удалил задание и снова его создал, повысив версию до той которая была изначально, сейчас все работает.
А ведь на таких тонких нюансах люди и валяться на экзаменах, судорожно пытаясь найти причину, лопатить код. Как итог можно вставать и уходить домой))))
Павел большое спасибо за уделенное время.

ALex85

  • Новичок
  • *
  • Сообщений: 1
Re: Билет 2. Спец по платформе V8
« Ответ #532 : Февраль 14, 2020, 03:44:10 pm »
всем привет. я правильно понимаю, в бухгалтерской задаче нужно в приходник тоже прописать движения в регистр бухгалтерии? а то без него же в расходнике всегда будет нулевой остаток

Shaker84

  • Новичок
  • *
  • Сообщений: 5
Re: Билет 2. Спец по платформе V8
« Ответ #533 : Февраль 14, 2020, 04:34:30 pm »
всем привет. я правильно понимаю, в бухгалтерской задаче нужно в приходник тоже прописать движения в регистр бухгалтерии? а то без него же в расходнике всегда будет нулевой остаток

 Я не стал в Приходной делать движения. Через документ Операция вводил приход товаров.

Михаил Проходцев

  • Проверенный
  • ***
  • Сообщений: 218
Re: Билет 2. Спец по платформе V8
« Ответ #534 : Февраль 15, 2020, 11:54:39 pm »
всем привет. я правильно понимаю, в бухгалтерской задаче нужно в приходник тоже прописать движения в регистр бухгалтерии? а то без него же в расходнике всегда будет нулевой остаток
Конечно, необходимо обеспечить наличие приходных движений в системе. Если не сказано ничего в условии, как это реализовать, то решает сам разработчик. Можно сформировать приходные движения как документом "Операция", так и документом "Приходная накладная".
Хотя если покопаться в архивах форума можно найти информацию,  что когда-то давно проверяющему не понравилось формирование движений документом "Операция",  а не документом "Приходная накладная", мол документ приходной составляет на экзамене цепочку товарно-складских документов и уже добавлен в каркасную, поэтому нужно было использовать именно его.
Но знаю, что один из экзаменаторов уточнял не так давно, что в такой ситуации формирование движений можно реализовывать на экзамене любым из указанных способов.
Специалист по платформе 8.3
Мои решения, описания подготовки, полезные ссылки:
https://expert.chistov.pro/public/537462/
http://1clancer.ru/catalog/3491